Diverses petites astuces

 

Astuce pour copier-coller telle quelle une formule d'une cellule dans une autre, donc sans que les références ne soient modifier

Clique sur la cellule où tu veux copier la formule.
Sélectionne la formule dans la barre des formules.
Utilise la touche CTRL+C (ou édition -copier) pour copier la formule qui est affichée dans la barre des formules.
Fait Entrée pour "sortir du mode édition de la cellule".
Sélectionne la cellule où tu veux copier cette formule.
Utilise la Touche CTRL +V ( ou édition coller) pour coller la formule.

Retour liens Excel


Dans une colonne additionner les valeurs une ligne sur deux pour en faire un total.

Une formule pour les cellules pairs:
=SOMMEPROD((MOD(LIGNE(A1:A10);2)=0)*A1:A10)
Une formule por les cellules impairs :
=SOMMEPROD((MOD(LIGNE(A1:A10);2)=1)*A1:A10)
Différence: = 0 ou = 1 et ce n'est pas du binaire...
Retour liens Excel


Rendre inactif le copier coller du clic gauche dans la cellule.

Macro installer dans module standard.
Sub InactifCopierColler()
'supprime le copier coller du clic gauche dans la cellule
Application.CommandBars("Cell").Controls(2).Enabled = False 'ou true
Application.CommandBars("Cell").Controls(3).Enabled = False 'ou True
End Sub
Retour liens Excel


Copie une page et mise en forme dans la même feuille.

Macro à installer dans la feuille :
Sub CopiePage()
'recopier une page et mise en forme sur la meme feuille
Dim N As Byte, Tot As Byte
Tot = Application.InputBox("Combien voulez-vous de pages ?", , , , , , , 1)
Range("A1:L26").Copy
Application.ScreenUpdating = False
For N = 1 To Tot
ActiveSheet.Paste Cells(26 * N + 1, 1)
Next
Application.CutCopyMode = False
End Sub
Retour liens Excel


Date et heure dans une cellule.

CTRL : (donne l'heure à un moment donné - sans réactualisation)
CTRL ; (donne la date à un jour donné)
=maintenant() dans une cellule formatée en hh:mm - donne l'heure et se réactualisera
La macro:
Private Sub Workbook_Open()
Cells(1, 1) = Time
End Sub
I nscrit l'heure de l'ouverture du classeur dans la cellule a1 de la feuille active à chaque ouverture du classeur sans se réactualiser
Retour liens Excel


Ouvrir une feuille bien définie d'Excel d'un classeur.

Condition que les feuille soient enregistrées par noms de mois
Exemple: Janvier, Février, Mars.....
Private Sub Workbook_Open()
Sheets(Format(Now(), "mmmm")).Select
End Sub
Retour liens Excel


Pour créer une même ligne sur plusieurs feuilles du même classeur.

Sélectionner plusieurs feuilles (groupe de travail), cliquer sur la première, puis Ctrl+Clic chaque feuille que tu veux sélectionner.
Une fois les feuilles sélectionnées, toute modification affecte l'ensemble des feuilles sélectionnées.
Reeetour liens Excel


Macro pour sélectionner une cellule précise.

Ici en exemple la cellule D1.
Sub AffichageCellule()
Dim MaCellule$
MaCellule = "D1"
Range(MaCellule).Select
ActiveWindow.ScrollRow = Range("D1").Row
ActiveWindow.ScrollColumn = Range("D1").Column
End Sub
Retour liens Excel